Will the Demand 5 app work with my version of Android?

The Demand 5 Android app requires Android version 4.1 (Jelly Bean) or above.

It can be installed on these Android devices:

  • All Samsung Galaxy devices
  • HTC One mini
  • Tesco Hudl
  • Kindle Fire HDX 7-inch
  • Kindle Fire HDX 8.9-inch
  • LG Optimus
  • Motorola Xoom
  • Nexus 10
  • Nexus 5
  • Nexus 7
  • Sony Xperia T
  • Sony Xperia U
  • Sony Xperia Z
  • Versus TouchTab 9.7 inch

To check if your device is compatible, log in to the Google Play Store and navigate to the Demand 5 app page.

For more information, see the following topic: Can I watch videos on my smartphone or tablet?