Why do I get the error ‘Application upgrade needed’ when I open Demand 5 on YouView?

This error appears with the following message:

'Sorry, you need to upgrade to a newer version of Demand 5. Within the YouView settings go to Device Management >> Update On Demand Players.'

This error is often caused by a connection problem, or a problem with your device.

Please follow the troubleshooting steps in the Video playback checklist and try again.

If you still have a problem, please contact us. You will find contact information in the Contact details article.